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1.Обзор начальной формы

Для программирования, связи и передачи данных на Durus необходимо использовать ПО Durus Development Software версии не ниже 3.3.
После запуска программы Durus Development Software открывается начальное окно программы.
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Нажатием на “File” или комбинацией клавиш Alt+F открыть основное выпадающее меню
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File=>New или Ctrl+N - создание новой программы, выбор языка программирования.

File=>New=>New FBD - создание новой программы на языке FBD.
File=>New=>New LAD - создание новой программы на языке LAD.
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File=>Open или Ctrl+O - открыть готовую программу. Можно выбрать два типа расширения:

*.gfb – программы на языке FBD или *.gen – программы на языке LAD
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File=>Recent File - открыть недавно используемые программы

File=>Exit - выход из программы

Help=>How to… или F1 - открыть помощь
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Help=>About Durus Development Software - открыть информацию о программном обеспечении.
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Панель инструментов
При нажатии на значок запустятся следующие начальные пункты меню:
	Значок
	Соответствующая команда меню
	Горячие клавиши
	Описание функций
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	File=>New=>New LAD
	
	Создание новой программы на языке LAD
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	File=>New=>New FBD
	
	Создание новой программы на языке FBD

	[image: image9.jpg]



	File=>Open
	Ctrl+O
	Открыть готовую программу
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	Help=>How to…
	F1
	Открыть помощь


2.Языки программирования

2.1.Язык программирования LAD
Применяется исключительно при программировании промышленных логических контроллеров и был создан для простого перехода от релейно-контакторных схем, к системам управления, построенных на логических контроллерах. Программирование заключается в прорисовке релейно-контакторной схемы устройства, в которой, в общем виде контакты являются входами, а катушки реле выходами. Вот пример программы написанной в LAD.

Имеется схема в которой лампочка загорится только при одновременной замыкании обоих контактов.
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И вот, как в этом случае будет выглядеть программа для контроллера.
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Сходства на лицо, хотя немного по-другому выглядят контакты и лампочка.
Означает это программа следующее: Если на входе I01 и на входе I02 имеется сигнал, то на выход Q01 тоже будет подан сигнал.

Конечно символов теперь в языке LAD очень много, и даже таких которые невозможно реализовать на реле, но тем не менее это самый простой и понятный язык программирования.

2.2.Язык программирования FBD

Тоже графический язык и тоже применяется для программирования только PLC.

Был создан для быстрого перехода с цифровых систем логического управления на логические контроллеры, а потому больше подойдет электронщикам.

Основан на графическом отображении логических элементов «И», «ИЛИ», «НЕ» и прочих для решения конкретной задачи управления. Например, если мы возьмем ту же схему
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и захотим написать для нее программу на языке FBD, то получится у нас, что то наподобие: 
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Смысл программа будет иметь такой: Если сигнал поступит со входа I01 и сигнал поступит со входа I02, то логический элемент «И» В001 подаст сигнал на выход Q01.

Язык программирования FBD немного сложнее чем LAD, но у него есть одно существенное преимущество: видны все линии связи от каждого элемента, что упрощает написание больших и путаных программ. 
3. Программирование

Создавать программу для управления АВР лучше на языке FBD. Он более функционален, возможно добавление более трех элементов логики (в языке LAD их именно три максимум).
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3.1.Подготовка

Прежде чем начать писать программу необходимо внимательно изучить ТЗ, распределить и присвоить все входные и выходные сигналы по входам, выходам контроллера.


Рассмотрим пример: есть два автоматических выключателя RecordPlus, с основного и резервного ввода. Каждый из автоматических выключателей имеет нормально открытый дополнительный контакт для сигнализации положения, моторный привод для включения, независимый расцепитель для выключения автомата. На каждом из вводов стоит реле контроля фаз с нормально открытыми контактами. Задача состоит в следующем: при нормальном состоянии основной сети включается основной автомат, резервный выключен. При аварийном состоянии основной сети и нормальном состоянии резервной  - основной автомат выключен, резервный включен.


Распределение  всех сигналов:



I01 – реле контроля фаз 1(основного ввода)



I02 – реле контроля фаз 2(резервного ввода)



I03 – дополнительный контакт состояния автоматического выключателя 1(основного)



I04 – дополнительный контакт состояния автоматического выключателя 2(резервного)



Q01 – моторный привод автоматического выключателя 1(основного)



Q02 – независимый расцепитель автоматического выключателя 1(основного)


Q03 – моторный привод автоматического выключателя 2(резервного)


Q04 – независимый расцепитель автоматического выключателя 2(резервного)


Сигналы можно распределять в любом удобном порядке, самое главное, чтобы входные сигналы соответствовали входным, а выходные – выходным.

3.2.Детализация алгоритма


Теперь необходимо определиться с алгоритмом программирования.

Основной автоматический выключатель включается при нормальном состоянии основной сети, то есть при наличии сигнала с реле контроля фаз1, отсутствия сигнала с дополнительного контакта состояния автоматического выключателя 1 и отсутствия сигнала с дополнительного контакта состояния автоматического выключателя 2 (для отсутствия встречного напряжения) подается сигнал на включение моторного привода автоматического выключателя 1: I01+NI03+NI04=Q01

Основной автоматический выключатель выключается при аварийном состоянии основной сети, то есть при отсутствии сигнала с реле контроля фаз1 и наличия сигнала с дополнительного контакта состояния автоматического выключателя 1 подается сигнал на включение независимого расцепителя автоматического выключателя 1: NI01+I03=Q02


Резервный автоматический выключатель включается при аварийном состоянии основной сети и нормальном состоянии резервной сети, то есть при отсутствии сигнала с реле контроля фаз1, наличии сигнала с реле контроля фаз2 и отсутствия сигнала с дополнительного контакта состояния автоматического выключателя 2 подается сигнал на включение моторного привода автоматического выключателя 2: NI01+I02+NI04=Q03

Резервный автоматический выключатель выключается при нормальном состоянии основной сети или аврийном состоянии резервной сети, то есть при наличии сигнала с реле контроля фаз1 или отсутствии сигнала с реле контроля фаз2 и наличии сигнала с дополнительного контакта состояния автоматического выключателя 2 подается сигнал на включение моторного привода автоматического выключателя 2: I01 OR NI02+I04=Q04
Итоговый алгоритм:



I01+NI03+NI04=Q01



NI01+I03=Q02


NI01+I02+NI04=Q03


I01 OR NI02+I04=Q04
3.3.Создание программы


3.3.1.Создание начальной формы для программирования
Выбор язык программирования FBD для новой программы File=>New=>New FBD.
В открывшемся окне File=>New.
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Открывается окно, где необходимо выбрать тип контроллера.
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Выбор типа контроллера необходим для автоматической конфигурации максимального количества входных/выходных сигналов, возможности расширения.

Открывается основное рабочее окно
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Оно состоит из следующих элементов:
1) Колонка панели инструментов (верхняя часть с функциональными кнопками)

2) Рабочая область (средняя белая часть)
3) Панель компонентов программирования (нижняя часть с функциональными кнопками)
3.3.2.Основные блоки программы.

Для реализации заданного в разделе 3.2. алгоритма необходимо воспользоваться панелью компонентов программирования.
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	Выбор
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	Все блоки
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	Соединить
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	Вырезать/разъединить соединения
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	Входа/выходы, константы
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	Удалить
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	Логические блоки
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	Комментарий
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	Функциональные блоки
	
	


Для программирования удобнее использовать[image: image29.png]


, потому что он включает в себя основные функции [image: image30.png]


, [image: image31.png]
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Необходимы следующие элементы:

- «вход» [image: image34.png]


 активизируется при появлении сигнала на соответствующем физическом входе;
- «выход» [image: image35.png]


 активизируется при появлении сигнала на входе блока и физически включает соответствующий выход;
- «И» [image: image36.png]


 логический элемент, активизируется при наличии сигнала на всех подключенных к нему входах;
- «ИЛИ» [image: image37.png]


 логический элемент, активизируется при наличии сигнала хотя бы на одном из подключенных к нему входах;
- «НЕ» [image: image38.png]


 логический элемент, активизируется при отсутствии сигнала с подключенного к нему входа.
[image: image39.jpg]



3.3.3.Реализация алгоритма
Перед началом программирования для создания все входов нажимаем на [image: image40.png]


 и на свободное место в рабочем поле 4 раза, для выходов - [image: image41.png]


 4 раза. К каждому элементу можно добавить комментарий в соответствии с выполняемой функцией для лучшего понимания процесса.
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Переходим к реализации алгоритма. Входы и выходы уже расставлены, осталось их объединить связями и логическими элементами. 

Рассмотрим первую строку логики: I01+NI03+NI04=Q01. Для ее реализации необходимо добавить элемент N - [image: image43.png]


 для I03 и I04,  «+» - [image: image44.png]


 для объединения I01, NI03 и NI04. Для этого щелкаем на изображение соответствующих значков в блоке [image: image45.png]


 или [image: image46.png]


 и на свободное место в рабочей области.
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Теперь необходимо объединить данные элементы связями. Выбираем блок [image: image48.png]


 и соединяем последовательно элементы «I01» с «AND», «I03» с «NOT I03», «I04» с «NOT I04»,  «NOT I03» с «AND», «NOT I04» с «AND» и «AND I01 NOTI03 NOTI04» с «Q01».
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Получилось следующее: если есть сигнал с реле контроля фаз основной сети, нет с дополнительного контакта основного автоматического выключателя и нет с дополнительного контакта резервного автоматического выключателя то подается сигнал на включение моторного привода основного автоматического выключателя. То есть I01+NI03+NI04=Q01 первая строчка алгоритма реализована.

Подобным образом реализуем и последующие строчки алгоритма. NI01+I03=Q02

Добавляем элементы [image: image50.png]


 и [image: image51.png]


 рядом с соответствующими блоками
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Добавляем связи с помощью [image: image53.png]


. «I01» с «NOT», «NOT I01» с «AND», «I03» с «AND», «AND NOT I01 I03» с «Q02».
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Если нет сигнала с реле контроля фаз основной сети, есть с дополнительного контакта основного автоматического выключателя, то подается сигнал на независимый расцепитель основного автоматического выключателя: NI01+I03=Q02

Следующая строчка: NI01+I02+NI04=Q03. Добавляем элементы [image: image55.png]


 и [image: image56.png]


 рядом с соответствующими блоками.
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Добавляем связи с помощью [image: image58.png]


. «NOTI01» с «AND», «I02» с «AND», «I04» с «NOT», «NOT I04» с «AND», «AND NOTI01 I02 NOTI04» с «Q03».
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Если нет сигнала с реле контроля фаз основной сети, есть сигнал реле контроля фаз резервной и нет сигнала с дополнительного контакта резервного автоматического выключателя то подается сигнал на включение моторного привода резервного автоматического выключателя: NI01+I02+NI04=Q03
Следующая строчка: I01 OR NI02+I04=Q04. Добавляем элементы [image: image60.png]


 , [image: image61.png]


 и [image: image62.png]


 рядом с соответствующими блоками.
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Добавляем связи с помощью [image: image64.png]


. «I01» с «OR», «I02» с «NOT», «NOTI02» с «OR», «OR I01 NOTI02» с «AND», «I04» с «AND», «AND OR I01 NOTI02 I04» c «Q04».
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Если есть сигнал с реле контроля фаз основной сети или нет сигнала с реле контроля фаз резервной сети и есть сигнал с дополнительного контакта резервного автоматического выключателя то подается сигнал на включение независимый расцепитель резервного автоматического выключателя: I01 OR NI02+I04=Q04


Все строчки алгоритма реализованы.
Данная программа не является единственным верным решением начального алгоритма. Её можно написать совершенно по-другому, используя другие связи и соединения логических модулей. Многое зависит от распределения входных/выходных сигналов и их вида (НО/НЗ).
Самое главное чтобы «включалось то при выключении того», а как будет это реализовано внутри контроллера – не столь важно.
3.3.4.Режим симуляции.


Режим симуляции очень полезен для проверки программы и алгоритма, он помогает избежать некоторых ошибок и сократить время на пуско-наладку уже с реальными элементами управления.

Для перехода в режим симуляции необходимо нажать Ctrl+I, либо на панели инструментов выбрать Operation=>Simulator, либо на панели инструментов нажать значок [image: image66.png]


. Выключить его можно теми же действиями, что и включить.

Если компьютер не соединен с контроллером, то нажав на [image: image67.png]


 на панели инструментов также можно включить режим симуляции и выключить [image: image68.png]


.

При включении данного режима появляется 4 окна. Для работы с АВР будет достаточно использовать только Input Status Tool, остальные можно закрыть.
[image: image69.jpg]




Данное окно показывает состояние входов/выходов контроллера и его блоков расширения. Можно управлять симуляцией входных сигналов, тем самым проверяя правильность написания программы и логику работы.

Для симулирования активации входных сигналов необходимо нажать на изображение соответствующего контакта в окне Input Status Tool или  на изображение входа в рабочей области. При активации элементов их отображение в окне Input Status Tool становится красным.


При запуске режима симуляции в программе написанной ранее должно получиться что то подобное. Активные блоки и связи становятся зелеными.
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Это начальное состояние программы. Для проверки алгоритма необходимо пройти построчно по его условиям:



I01+NI03+NI04=Q01


NI01+I03=Q02


NI01+I02+NI04=Q03


I01 OR NI02+I04=Q04

Рассмотрим первую строку логики: I01+NI03+NI04=Q01. Для правильности ее реализации необходимо чтобы на I01 присутствовал сигнал, на I03 отсутствовал, состояние других входов для выхода Q01 не имеет значения. То есть для подачи сигнала на Q01 в данном состоянии входов необходимо активировать I01.
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Получилось следующее: если есть сигнал с реле контроля фаз основной сети, нет с дополнительного контакта основного автоматического выключателя и нет с дополнительного контакта резервного автоматического выключателя то подается сигнал на включение моторного привода основного автоматического выключателя.

После включения моторного привода автоматический выключатель должен включиться, и активироваться дополнительный контакт состояния. Просимулируем активацию дополнительного контакта состояния основного автоматического выключателя I03.
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При появлении сигнала о включении автоматического выключателя моторный привод отключается.

Рассмотрим вторую строку логики: NI01+I03=Q02. Для подачи сигнала на Q02 из предыдущего состояния необходимо отключить сигнал с I01.
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Если нет сигнала с реле контроля фаз основной сети, есть с дополнительного контакта основного автоматического выключателя, то подается сигнал на независимый расцепитель основного автоматического выключателя. 

После включения независимого расцепителя автоматический выключатель должен выключиться, и отключить дополнительный контакт состояния. Просимулируем отключение дополнительного контакта состояния основного автоматического выключателя I03.
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При отсутствии сигнала о включении автоматического выключателя независимый расцепитель отключается. Алгоритм переходит в начальное состояние.

Рассмотрим третью строку логики: NI01+I02+NI04=Q03. Для подачи сигнала на Q03 из текущего состояния необходимо подать сигнал с I02.
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Если нет сигнала с реле контроля фаз основной сети, есть сигнал реле контроля фаз резервной и нет сигнала с дополнительного контакта резервного автоматического выключателя то подается сигнал на включение моторного привода резервного автоматического выключателя.

После включения моторного привода автоматический выключатель должен включиться, и активироваться дополнительный контакт состояния. Просимулируем активацию дополнительного контакта состояния основного автоматического выключателя I04.

[image: image76.jpg]Pene ronTpona das 1

Pene romrpons das 2

Hom.

Hom.

101

Moropueni npueon 1
BOD4 Q01

BO00S

102

=

HesaEmcmmuii pacmemurens 1
BODZ Qo2

IIII- I

xommakr 1

BO06

103

< ]

=8

Momopusii mpuEoA 2
BOD3 Qn3

|Iii||- I

B007

B00Y

koHTAKT 2
104

=

28

HesaBuCHMMiE pacnemmrens 2
BOOL on4

BO08

]

Input Status Tool





При появлении сигнала о включении автоматического выключателя моторный привод отключается.

Рассмотрим четвертую строку логики: I01 OR NI02+I04=Q04. Для подачи сигнала на Q04 из предыдущего состояния необходимо отключить сигнал с I02 или подать сигнал с I01. Проверим сначала отключение сигнала I02.
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Если нет сигнала с реле контроля фаз резервной сети, есть с дополнительного контакта резервного автоматического выключателя, то подается сигнал на независимый расцепитель резервного автоматического выключателя. 

После включения независимого расцепителя автоматический выключатель должен выключиться, и отключить дополнительный контакт состояния. Просимулируем отключение дополнительного контакта состояния основного автоматического выключателя I04.
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При отсутствии сигнала о включении автоматического выключателя независимый расцепитель отключается. Алгоритм переходит в начальное состояние.

Рассмотрим четвертую строку логики: I01 OR NI02+I04=Q04. Проверим появление сигнала I01.
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Если есть сигнал с реле контроля фаз основной сети, есть с дополнительного контакта резервного автоматического выключателя, то подается сигнал на независимый расцепитель резервного автоматического выключателя. 

После включения независимого расцепителя автоматический выключатель должен выключиться, и отключить дополнительный контакт состояния. Просимулируем отключение дополнительного контакта состояния основного автоматического выключателя I04.
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При отсутствии сигнала о включении автоматического выключателя независимый расцепитель отключается. Выполняются условия для включения моторного привода основного автоматического выключателя.

В режиме симуляции проверены все строчки алгоритма, симуляция ошибок не выявила. Программа написана правильно, можно ее записывать на контроллер, управляющий данным алгоритмом.

4. Работа с таймерами и счетчиками.

Для многих ТЗ для АВР достаточно использование только входных, выходных элементов и простейших элементов логики для реализации алгоритма. Но иногда необходимы функции таймеров и счетчиков для возможности задержки включения, счета количества аварийных сигналов и тд. Максимально возможно использовать 14 таймеров и 14 счетчиков.
4.1.Таймеры

Для реализации программ АВР чаще всего используются таймеры задержки включения и таймеры задержки выключения.
Для создания таймера нужно нажать на панели компонентов программирования [image: image81.png]


 или [image: image82.png]


,выбрать [image: image83.png]


 и нажать на свободное место в рабочей области. Открывается окно свойств таймера:
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Mode – режим таймера. Таймер имеет 8 режимов работы 0-7. Таймер задержки включения – 1 режим, задержки выключения – 3 режим. Time number – номер таймера в программе. Time Base – кратность устанавливаемого времени. Current Value – текущее время. Present Value – заданное время. Symbol – комментарий к блоку.
 Подробную информацию о режимах можно посмотреть нажав F1 или Help=>How to… в помощи в разделе Block Instruction=>Function Block=>Timer.
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4.1.1.Таймер задержки включения.


Номер таймера задержки включения (Mode) – 1. Он срабатывает после заданного времени (Present Value) наличия на входе таймера сигнала, выключается при пропадании входного сигнала и не включается при наличии сигнала меньшее время чем задано.
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Создадим маленькую программу управления лампочкой по следующему ТЗ: лампочка включается при наличии сигнала о включении с пятисекундной выдержкой и выключается при пропадании входного сигнала. Для этого понадобится один вход, один выход и один таймер с режимом работы – 1 и заданным временем 5 секунд.
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Должно получиться что-то подобное:
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Включим режим симуляции для проверки работоспособности схемы. Активизируем I01. На таймере начался отсчет времени.
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При достижении заданного времени 5 секунд таймер подает сигнал на Q01.
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При пропадании сигнала на I01 сигнал пропадает, на таймере и не поступает на Q1. Переход в начальное состояние. Алгоритм выполнен.
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4.1.2. Таймер задержки выключения.


Номер таймера задержки выключения (Mode) – 3. Рассмотрим его основную функцию. Он включается при появлении сигнала на входе таймера и выключается после заданного времени при пропадании входного сигнала.
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Отредактируем уже созданную программу по следующему ТЗ: лампочка включается при наличии сигнала о включении с пятисекундной выдержкой. Вход, выход и связи оставляем те же, меняется только режим работы таймера – с 1 на 3.

Включим режим симуляции для проверки работоспособности схемы.
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 Активизируем I01. Активизируется таймер и появляется сигнал на входе Q01.
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При отключении входного сигнала таймер остается активированным заданное время и подает сигнал на вход Q01.
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По истечении заданного времени и отсутствии входного сигнала таймер отключается, сигнал на выходе Q01 отсутствует. Переход в начальное состояние, алгоритм выполнен.
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4.2.Счетчики
Для реализации программ АВР чаще всего используются обычные счетчики без дополнительных функций со сбросом.
Для создания счетчика нужно нажать на панели компонентов программирования [image: image97.png]


 или [image: image98.png]


,выбрать [image: image99.png]


 и нажать на свободное место в рабочей области. Открывается окно свойств счетчика:
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Mode – режим счетчика. Счетчик имеет 9 режимов работы 0-8 (7 и 8 – высокоскоростные и доступны только для некоторых моделей). Счетчик без дополнительных функций со сбросом - 1. Counter number – номер счетчика в программе. Current Value – текущее количество. Present Value – заданное количество. Symbol – комментарий к блоку.
 Подробную информацию о режимах можно посмотреть нажав F1 или Help=>How to… в помощи в разделе Block Instruction=>Function Block=>Counter.
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4.2.1. Счетчик без дополнительных функций со сбросом

Номер счетчика без дополнительных функций со сбросом (Mode) – 1. Он срабатывает после достижения заданного количества сигналов и отключается при появлении сигнала сброса.
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Примем следующее ТЗ: при появлении три раза подряд сигнала с кнопки включения поступает сигнал на лампочку, при появлении сигнала с кнопки выключения счетчик сбрасывается, лампа выключается (если была включена).


Для реализации понадобится та же программа, но с заменой таймера на счетчик, выставление в нем значения «3» и добавлением кнопки выключения (I02).
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Должно получиться что-то подобное:
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Включим режим симуляции для проверки работоспособности схемы. Активизируем I01, на счетчике отображается текущее его состояние. В данный момент «Cur Value: 1».
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Необходимо выключить и включить вход I01 еще 2 раза до достижения счетчиком заданного значения:
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Счетчик активируется и подает выходной сигнал на Q01. Для выключения счетчика необходимо нажать на I02, подав сигнал на сброс.
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Сигнал с счетчика на выход пропадает, при отключении I02 алгоритм переходит в начальное состояние.

Рассмотрены все основные элементы для реализации алгоритмов для АВР. Всю дополнительную информацию можно найти в помощи.
5.Работа с контроллером.

5.1.Подключение

Подключение контроллера происходит через RS 232 с помощью кабеля IC210CBL001.

Для соединения с контроллера с ПО необходимо нажать на «Link Com Port» [image: image108.png]


 в панели инструментов, или Options=>Link Com Port, или сочетание клавиш Ctrl+L. Откроется следующее окно, где необходимо выбрать порт для соединения и нажать Link.
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 Если контроллер на данном порте отсутствует, то появится следующее сообщение об ошибке:
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При соединении окно Link Com Port закрывается и в панели инструментов становятся доступными следующие действия:
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 - Monitor, также можно запустить через Options=>Monitor или сочетание клавиш Ctrl+M. Позволяет отслеживать состояние программы в ПЛК в on-line режиме.
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 - Read или Options=> Read. Считать программу с контроллера

[image: image114.png]


 - Write или Options=> Write. Записать программу в контроллер.
5.2.Запись данных

После соединения с контроллером на него можно записывать готовую программу. Для записи необходимо нажать [image: image115.png]


, после появится следующее окно с требованием подтверждения записи и удаления старой программы:
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Необходимо выбрать «YES», начнется запись. По ее завершении появится следующее окно:
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5.3.Мониторинг

Режим мониторинга позволяет отслеживать состояние программы в режиме on-line с реальными входными и выходными сигналами. Его также можно запустить с помощью [image: image118.png]


. При его запуске появляется следующее окно, позволяющее считать программу с контроллера. 
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Этого можно не делать, если программа только что передана, так как она совпадает с переданной. В случае считывания текущая открытая программа удаляется и на нее записывается программа с контроллера. Появляется окно с запросом сохранить старую программу:
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В режиме мониторинга открываются те же окна, что и при симуляции, все активные связи и блоки становятся розовыми.
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5.4.Режимы работы

У контроллеров два режима работы [image: image122.png]


 и [image: image123.png]


. 
[image: image124.png]


, Options=>RUN или Ctrl+R контроллер активен.
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 или Options=>STOP контролер не активен, алгоритм не работает.

Если происходит отключение кабеля от контроллера в режиме RUN, то он автоматически переходит в STOP. Для того, чтобы произвести «безопасное извлечение» необходимо сначала нажать [image: image126.png]


 (Options=>Quit или Ctrl+Q) для отсоединения контроллера и сохранения режима RUN в нем.
6. Схемы подключения

Все контроллеры по виду подключения можно разбить следующим образом:

- Вид напряжения питания:


- переменный ток;


- постоянный ток.

- Вид выходов:


- реле;


- напряжение.


Ниже представлены типовые принципиальные схемы вариантов подключения.


Питание постоянного тока, выход – реле:
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Питание постоянного тока, выход – напряжение:
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Питание переменного тока, выход – реле:
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